Page 1 of 1

Kommunikation Statlink-Optima 900

PostPosted: Fri Dec 02, 2016 10:28
by Ski
Var söker man orsaken till att det står "Idle 2016-12-02" i stausfältet nere till höger? Verkar inte som att några värden uppdateras. I rapportfilerna återfinns ett och samma värde. "Communication with Heatpump is OK"

Har i somras råkat ut för att bara värden från inomhusdelen uppdateras medan inga noteringar om uppdaterade värden från utedelen visar sig. Gick över med en omstart.

Kör en USB-TTY omvandlare. Vid omstart måste interfacet göras spänningslöst (reset?) från datorsidan vid omstart. Annars kommer inte kommunikationen igång. Statusraden visar Request version info eller något i den stilen. Finns något sätt att göra reset menom att skriva kommando till serieutgången?

Kan tillägga att jag för närvarande kör Statlink - Wine - Ubuntu.

Re: Kommunikation Statlink-Optima 900

PostPosted: Mon Dec 05, 2016 11:26
by Husdata
Hej.
Det är väldigt svårt att avgöra om det är något problem med din WINW setup och dess serieport.

Du skulle kunna gå in in StatLink setup och sätta logen till "All".
Ta bort alla logg filer och starta sedan StatLink.

Då kanske du kan se i loggfilen fart det tar stopp.

Re: Kommunikation Statlink-Optima 900

PostPosted: Mon Dec 05, 2016 18:40
by Ski
Tack. Skall kolla loggarna.

Med all respekt för den tid du lagt ner för att komma på hur värmepumpens protokoll ser ut, men kan du ge info om vad för kommando man skall skicka till interfacet och vilket svar man skall få vid startup?

Finns något resetkommando man kan ge på ttyutgången?

Re: Kommunikation Statlink-Optima 900

PostPosted: Mon Dec 05, 2016 20:45
by Husdata
Då jag inte vet vem du är har jag ingen information om vad du har för interface eller värmepump. Därför kan jag inte svara på några djupare frågor.

Re: Kommunikation Statlink-Optima 900

PostPosted: Tue Dec 06, 2016 16:32
by Ski
Hej.
Pannan är en IVT Optoma 290 A/W. Interfacet ett CANBUSinterface, ett av de första du levererade runt 2007eller 08. StatLink ver 4.0.0 eventuellt med någon patch du själv gjorde via nätet. I början var det lite trögt att kommunikationen gick igång, man fick ibland vänta 5-10 minuter innan den startade. Sedan jag började med USB-tty converten för ett halvår sedan hänger sig systemet regelbundet och inga värden uppdateras. Vid omstart väntar StatlLink på firmware version om inte inte interfacet gjorts spänningslöst på datorsidan (reset?) vilket inte låter sig göras när jag sitter på annan plats och jobbar via nätet.

För en stund sedan aktiverade jag loggning. Du ser ett utdrag nedan. Jag startade om utan reset av interfacet eftersom jag fysiskt inte kommer åt datorn. Det sista värde som uppdaterades innan stoppet var varmvatten T3 som det finns en not om i loggen strax före omstart. Innan omstart kommer ERROR - INFO raderna så där en gång/sekund.

Den slutsats jag tror mig kunna dra är att antingen är det problem med USB-tty omvandlingen eller kan det vara interfacet? Vid något tillfälle har kommunikationen kommit igång spontant. StatLink verkar fungera OK.

ERROR:2016-12-06 15:16:33 Src:PicCom-Rego800cmdProc, General error processing Rego 800 data
INFO:2016-12-06 15:16:34 Src:frmPicCom-Rego800CmdProc, MultiInt2 response. Varmvatten T3, Value=0
ERROR:2016-12-06 15:16:34 Src:PicCom-Rego800cmdProc, General error processing Rego 800 data
INFO:2016-12-06 15:16:34 Src:LogAndSend-Intraday, Stored Intraday.xml file
ERROR:2016-12-06 15:16:33 Src:PicCom-Rego800cmdProc, General error processing Rego 800 data
INFO:2016-12-06 15:16:34 Src:frmPicCom-Rego800CmdProc, MultiInt2 response. Varmvatten T3, Value=0
ERROR:2016-12-06 15:16:34 Src:PicCom-Rego800cmdProc, General error processing Rego 800 data
INFO:2016-12-06 15:16:34 Src:LogAndSend-Intraday, Stored Intraday.xml file
INFO:2016-12-06 15:16:35 Src:Main-QueryUnload, Software shutdown

................Här gjordes omstart.

INFO:2016-12-06 15:30:54 Src:LogAndSend-GetWebData, Connecting to Webservice, GetWebData...
ERROR:2016-12-06 15:30:54 Src:LogAndSend-WsConnect, Cannot connect to online service at www.husdata.se
WSDLReader:XML Parser failed at linenumber 0, lineposition 0, reason is: error HRESULT=0x1: Ogiltig funktio$
- WSDLReader:Loading of the WSDL file failed HRESULT=0x80070057 - Client:One of the parameters supplied is$
INFO:2016-12-06 15:30:57 Src:SerialCom, Opened Com port 1 for Multi Interface 2
INFO:2016-12-06 15:31:03 Src:LogAndSend-Intraday, Loaded Intraday.xml file
INFO:2016-12-06 15:31:05 Src:PICcomm-SendCommand, MultiInt2, Version request...
INFO:2016-12-06 15:31:06 Src:PICcomm-SendCommand, MultiInt2, Version request...
INFO:2016-12-06 15:31:11 Src:PICcomm-SendCommand, MultiInt2, Version request...
INFO:2016-12-06 15:31:16 Src:PICcomm-SendCommand, MultiInt2, Version request...
INFO:2016-12-06 15:31:21 Src:PICcomm-SendCommand, MultiInt2, Version request...

Sedan fortsätter det i det oändliga....

Re: Kommunikation Statlink-Optima 900

PostPosted: Fri Dec 09, 2016 19:24
by Husdata
Detta tyder på att seriella kommunikationen inte riktigt fungerar stabilt.
Vi kör inte längre med dessa interface men principen är den samma.
Jag har en massa sånna interface som du har (fast nyare version) liggande och kan skicka dig ett nytt om du vill testa.
Hör av dig via support formuläret i så fall.

Re: Kommunikation Statlink-Optima 900

PostPosted: Tue Dec 13, 2016 11:26
by Ski
Det går någon vecka mellan stoppen så det är lite segt att felsöka och dessutom sitter jag som sagt inte fysiskt vid värmepumpen. Jag tror att StatLink är helt oskyldigt. Det kan vara interfacet men det kan också vara Wine eller USB-TTY omvandlingen. Min kompetens räcker inte till att felsöka de senare alternativen så jag börjar med interfacet. Hör av mig via mail. Tänk om alla företag skötte sim support på samma utmärkta sätt som Husdata.